WoW Freedom

Full Version: WoW and Wine Disaster
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So running the game through Wine carried over many issues from the MoP version. There's still massive texture issues and sometimes rendering issues. Forcing the game into OpenGL mode doesn't resolve any issues. The game cannot be loaded at all if the graphics are past the lowest possible setting. Otherwise this or a completely black screen occurs:



<div class='spoiler_toggle'>Spoiler: click to toggle</div><div class="spoiler" style="display:none;">

<IMG src="http://i.imgur.com/HAcMN7r.png"><s>[img]</s>[url="http://i.imgur.com/HAcMN7r.png">http://i.imgur.com/HAcMN7r.png[/url]<e>[/img]</e></IMG>

</div>





When running at the lowest settings, textures load improperly, flicker, or are completely broken at random.



<div class='spoiler_toggle'>Spoiler: click to toggle</div><div class="spoiler" style="display:none;">

<IMG src="http://i.imgur.com/a6z0Aq5.jpg"><s>[img]</s>[url="http://i.imgur.com/a6z0Aq5.jpg">http://i.imgur.com/a6z0Aq5.jpg[/url]<e>[/img]</e></IMG>



<IMG src="http://i.imgur.com/hci9zpW.jpg"><s>[img]</s>[url="http://i.imgur.com/hci9zpW.jpg">http://i.imgur.com/hci9zpW.jpg[/url]<e>[/img]</e></IMG>



<IMG src="http://i.imgur.com/Nl4uaqI.jpg"><s>[img]</s>[url="http://i.imgur.com/Nl4uaqI.jpg">http://i.imgur.com/Nl4uaqI.jpg[/url]<e>[/img]</e></IMG>



<IMG src="http://i.imgur.com/yrJ5RRP.jpg"><s>[img]</s>[url="http://i.imgur.com/yrJ5RRP.jpg">http://i.imgur.com/yrJ5RRP.jpg[/url]<e>[/img]</e></IMG>

</div>



Texture filtering settings do nothing, applying various Winetricks do nothing, OpenGL does nothing... I'm at a bit of a standstill. The game works perfectly when I swap to my Bootcamp Windows partition, but swapping to Windows just for a game is rather frustrating. Especially since I only have Photoshop on OS X and it's my primary application.



In short, feelsbadman





Quick edit:

In Windows I'm able to run the game in Ultra with no problems. The issue isn't hardware as much as it is somewhere in the emulation. Either I'm missing a Winetrick or a setting somewhere in the config.wtf and finding exactly what is driving me mad.
Welp, I can't really help much (I'm not a Mac person) other than suggest looking for similar issues on battle.net forums, because these are likely not Freedom-specific problems.
Check video drivers, but like aze said I'm not a mac person, but I'm sure someone else has had this kind of video issue before.
I managed to find means to fix it! Lemme detail it in case someone has this issue in the future.



I'm running on an intel graphics iMac.



Use Wineskin instead of the default Wine emulation.

Use Wrapper "Wineskin 2.6.2" and Engine "WS9Wine1.9.15".

Once the wrapper is installed, select to view your wrapper in finder. Right click and select "Show Package Contents".

Navigate to drive_c > Program Files

Move your Freedom installation into here

Navigate to the root of your wrapper and run the Wineskin in there.

Select "Advanced"

Beside Windows EXE, select "Browse" and navigate to your FreedomWoW.exe or whatever it's named. Whatever you name your default Freedom application,

At the bottom of the window, select "Set Screen Options"

On the bottom right, make sure all four boxes are checked (Use Mac Driver instead of X11, Decorate Windows, Auto Detect GPU Infor for Direct 3D, and Use Direct3D Boost if available)

Select Done

In the top, go to "Tools"

Run Config Utility (winecfg)

In the Applications tab that it loads by default, set your Windows version to Windows 7

In the Libraries tab, add the following overrides: d3dcompiler_43, d3dx9_43, wined3d-csmt

They should all be set to native, builtin

Select Okay

Test run to be safe!



Having Wineskin use the Mac Driver eliminates the "Your driver is out of date" error. Having those libraries <I><s></s>and<e></e></I> the 3D boost enabled allows the game to be run on ultra just as if I was playing on Windows.



Edit: You might want to move the wrapped up application from it's default directory or you might lose it. If it's still in the default directory and you do lose it, make a new wrapper and view it in finder.
install from one of azrerocs posts and essentially use this to convert to mac right?

(08-08-2016, 03:09 PM)SachikoMaeda Wrote: [ -> ]I managed to find means to fix it! Lemme detail it in case someone has this issue in the future.



I'm running on an intel graphics iMac.



Use Wineskin instead of the default Wine emulation.

Use Wrapper "Wineskin 2.6.2" and Engine "WS9Wine1.9.15".

Once the wrapper is installed, select to view your wrapper in finder. Right click and select "Show Package Contents".

Navigate to drive_c > Program Files

Move your Freedom installation into here

Navigate to the root of your wrapper and run the Wineskin in there.

Select "Advanced"

Beside Windows EXE, select "Browse" and navigate to your FreedomWoW.exe or whatever it's named. Whatever you name your default Freedom application,

At the bottom of the window, select "Set Screen Options"

On the bottom right, make sure all four boxes are checked (Use Mac Driver instead of X11, Decorate Windows, Auto Detect GPU Infor for Direct 3D, and Use Direct3D Boost if available)

Select Done

In the top, go to "Tools"

Run Config Utility (winecfg)

In the Applications tab that it loads by default, set your Windows version to Windows 7

In the Libraries tab, add the following overrides: d3dcompiler_43, d3dx9_43, wined3d-csmt

They should all be set to native, builtin

Select Okay

Test run to be safe!



Having Wineskin use the Mac Driver eliminates the "Your driver is out of date" error. Having those libraries <I><s></s>and<e></e></I> the 3D boost enabled allows the game to be run on ultra just as if I was playing on Windows.



Edit: You might want to move the wrapped up application from it's default directory or you might lose it. If it's still in the default directory and you do lose it, make a new wrapper and view it in finder.



Thanks! So I'm installing from Azrerocs old thread and using this to convert to mac right? Been a long long time since I've messed around in some WoW folders
yeah running into several walls. Got Winzip. Wine and all that but unable to get any of that old WoW installer nostalgia
You have to download the Windows client available to torrent here https://drive.google.com/open?id=0B5mIUW...0J1blJvMVU
(05-04-2018, 03:24 PM)SachikoMaeda Wrote: [ -> ]You have to download the Windows client available to torrent here https://drive.google.com/open?id=0B5mIUW...0J1blJvMVU

I'm having issues on the install through wine step. I have the wrapper made and the torrent and patch within the main WoW file within program files within drive C. but when I try to install with wineskin and use "Choose" "move" or "copy" it doesn't allow me to copy the entire Wrapper folder or to go into the wrapper's icon and select the launcher exe because it is greyed out. How did you get around that? anyone? Please help
So I've gotten a bit further using unarchiver instead of winzip. way easier for me. But stuck on the install step.. changed everything as listed in advanced, did config tool, test run completed after a few fails and i got the folder placed properly in applications. I even got the WoW icon in my dock at the bottom of the screen but no installer window, it got as far as asking me my language and some sort of failure happened.. Now I've tried installing after the successful test run, and I'm stuck on "wineskin is currently busy..." Will I eventually be seeing a warcraft installer if this goes right? or will this small wineskin window be the installer window?