[-]
Server Time

[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Useful Links
Forums
Mini-manager
Rules
Tech Support
Events Calendar
Commands Listing

[-]
Latest Threads
Artifact Guide and Appearances
Last Post: zackaroth
10-14-2019 11:36 PM
» Replies: 0
» Views: 99
Zelly who?
Last Post: Talona
10-02-2019 04:59 PM
» Replies: 4
» Views: 181
We need YOU to help make Freedom better!
Last Post: Loxmardin
09-29-2019 12:08 PM
» Replies: 2
» Views: 669
Sup y'all, it's me.
Last Post: Drew
09-24-2019 05:07 PM
» Replies: 7
» Views: 231
Legion Invasions
Last Post: zackaroth
09-16-2019 01:55 PM
» Replies: 0
» Views: 103

[-]
Who's Online
There are currently no members online.

Engineering items still req. engineering ranks
#1
Character(s): Lou

What happened: Tried to equip [Flying Tiger Goggles] (4368) and got the message "<COLOR color="#EE4A2D"><s></s>You do not have the require proficiency for that item"

Where: Anywhere, sure.

How: Try to equip one.
I wish you all the luck in the world.
Reply


Messages In This Thread

Forum Jump:


Users browsing this thread: 1 Guest(s)