[-]
Server Time


[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Useful Links
Forums
Mini-manager
Rules
Tech Support
Events Calendar
Commands Listing

[-]
Latest Threads
Back
Last Post: Aphetoros
01-19-2020 11:25 AM
» Replies: 1
» Views: 62
Episode 2: thepharaoh strikes again.
Last Post: Caravan
01-04-2020 02:48 AM
» Replies: 5
» Views: 311
Azsuna Storyline
Last Post: zackaroth
12-01-2019 07:13 PM
» Replies: 0
» Views: 266
Artifact Guide and Appearances
Last Post: Talona
10-27-2019 05:30 PM
» Replies: 1
» Views: 536
Zelly who?
Last Post: Talona
10-02-2019 04:59 PM
» Replies: 4
» Views: 732

[-]
Who's Online
There are currently 5 online users. [Complete List]
» 1 Member(s) | 4 Guest(s)
Kukamang

Engineering items still req. engineering ranks
#1
Character(s): Lou

What happened: Tried to equip [Flying Tiger Goggles] (4368) and got the message "<COLOR color="#EE4A2D"><s></s>You do not have the require proficiency for that item"

Where: Anywhere, sure.

How: Try to equip one.
I wish you all the luck in the world.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)